首页 » 运维 » 常用软件 » 正文

aix6.1安装GCC 内附rpm最新下载地址

需要在6.1上安装memcached,所有需要先安装gcc

gcc rpm包让我一顿好找啊…..网上地址要么不对,要么不全,头疼

相关安装包如下:

ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/gcc/gcc-4.2.0-3.aix6.1.ppc.rpm

ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/gcc/gcc-cplusplus-4.2.0-3.aix6.1.ppc.rpm

ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/gcc/libstdcplusplus-4.2.0-3.aix6.1.ppc.rpm

ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/gcc/libstdcplusplus-devel-4.2.0-3.aix6.1.ppc.rpm

ftp://public.dhe.ibm.com/aix/freeSoftware/aixtoolbox/RPMS/ppc/gcc/libgcc-4.2.0-3.aix6.1.ppc.rpm

下载完成后,root执行如下命令:

# rpm -ivh gcc-4.2.0-3.aix6.1.ppc.rpm

# rpm -ivh libgcc-4.2.0-3.aix6.1.ppc.rpm

# rpm -ivh libstdcplusplus-4.2.0-3.aix6.1.ppc.rpm

# rpm -ivh libstdcplusplus-devel-4.2.0-3.aix6.1.ppc.rpm

# rpm -ivh gcc-cplusplus-4.2.0-3.aix6.1.ppc.rpm

执行完成,gcc已经装好了

———————分割——————————-

memcached 安装

两个包

libevent-1.4.13-stable.tar.gz

memcached-1.4.5.tar.gz

libevent 安装:

tar -xvf libevent-2.0.20-stable.tar.gz

cd libevent-2.0.20-stable

./configure –prefix=/usr

make

make install

memcached安装:

tar -xvf memcached-1.4.15.tar.gz

cd memcached-1.4.15

./configure –prefix=/user –with-libevent=/user

此处需要修改相关文件

memcached.h

thread.c

memcached.c

将 thread_init 改成其他名字,如thread_init_memcached

make

make install

启动命令如下

/user/bin/memcached

./memcached -d -c 5120 -m 512 -u root

 

 

发表评论